Any idea what service pack your Win2k machine was at?  I saw the same issue with Explorer, but that was an SP3 machine - I've got to test with SP4.
Also, is there a way to disable the message - "Your current security settings prohibit running ActiveX controls on this page. Therefore, the page may not display correctly."...?

Fion