this may not work, and usual "touch the registry at your own risk" warnings apply...

you could try setting the following registry keys to a larger number.

browse to...
HKEY_CURRENT_USER\software\Microsoft\Internet Account Manager\Accounts 

The settings will be within the separate account folders. For example:
   HKEY_CURRENT_USER\software\Microsoft\Internet Account
   Manager\Accounts\00000006 The keys for the server timeout settings are:
   "IMAP Timeout"=dword:0000012c "SMTP Timeout"=dword:0000012c

values are in hex in seconds...

cheers
jeff