This error happens consistently when trying to access the site from FireFox 2.0.

Pathetic. 

Client side issues are perhaps understandable and forgivable since true cross-browser compatibility remains a moving target, but breaking the server code because you're using a different browser is just inexcusable.

Mad