Your probably getting a "beat signal" due to an interaction between the Power Brick's operating Frequency the Display's horizontal rate.

So if your monitor supports it, try changing the vertical refresh rate, which in turn changes all of the other related timings, including the horizontal. ie For Win XP, 2K or 2K3, right-click Desktop, Properties, Settings tab, Advanced button, Monitor tab, Vertical Refresh.

The problem should go away using DVI as it's a digital output, but you never know.