Maybe they're hoping somebody will get off there arse and fix the Group Policy Preference Client and Remote Server Administration Tools so that they can actually be installed after SP2 rather than leaving you up a certain creek without a paddle if you forget to install them first.

Not that it's caused me a bloomin headache all day or anything....

Was it really too much to ask for these to have been rolled into the service pack like any sane person would have done, eh, eh? Bah....