I've installed VPC 2007 SP1 yesterday and it runs fine, no warnings about unsupported OS whatsoever.