dahat said:
W3bbo said:
*snip*
WP7 requires the latest Snapdragon processors

[citation needed]

There are threads on the XDA Developers Forums created by owners of WM6.x devices asking why they can't get WP7 working on their phone.

 

Here is one such thread, where the lack of a Snapdragon processor is cited as the main reason why it won't work on older devices.