In Windows Server 8, you can add .NET 3.5 as a feature (.NET 4.5 is installed by default), so I'm assuming you can in Windows 8 as well.