@Steve01

As I said:  "jQuery 1.9  will be the last version to support so-called 'legacy' IE"

At the 1.9/2.0 branch, the functionality will be the same, and 1.9 will be maintained for bug-fixes.

However, from that point onwards (version >= 2) jQuery will NOT support legacy IE and this means that future development on jQuery will not support IE6/7/8

What they are saying is, that if you need Legacy IE support, you can continue to use versions up to 1.9, but that all development beyond that point will be without IE6/7/8 support.