Something wrong with your cleartype settings? Or your monitor settings?