Did it set up a proxy by any chance? Check Tools / Internet Options / Connections / Lan Settings