, blowdart wrote

Did it set up a proxy by any chance? Check Tools / Internet Options / Connections / Lan Settings

I've checked, and it hasn't set up a proxy.