@JoshRoss:

downgrade to 0.5 firmware that doesn't cripple your vocabulary.