, vesuvius wrote

*snip*

I did genuinely post a link above with the words sys admins and target this specific post;

Hi,

Digging up it only for information. I had a similar problem but found a solution.
The problem is that the WS12 in default use .NET 4.5 and Exchange 2010 need .NET 3.5. Second problem is that you cant install .NET 3.5 on .NET 4.5.

Short scheme what you need to do to fix this:
- Remove .NET 4.5 (it remove GUI and PS3)
- Via dism install .NET 3
- Install .NET 4 and GUI

And next when you see you have both .NET 3.5 and 4.5, you can normally install exchange 2010.

 

That (community) answer makes no sense to be honest.

Second problem is that you cant install .NET 3.5 on .NET 4.5.

is untrue. You most certainly can. Mind you it takes an entire whitepaper to list the options, but DSIM is the ugliest option.

  1. In Server Manager, click Manage, then select Add Roles and Features to launch the Add Roles and Features Wizard.
  2. Click Next at the Before you begin screen.
  3. At the Select installation type screen, select Role-based or feature-based installation and click Next.
  4. On the Select destination server screen, select the target server and click Next.
  5. On the Select server roles screen, click Next.
  6. On the Select features screen, check the box next to .Net Framework 3.5 Features and click Next.
  7. On the Confirm installation selections screen, a warning will be displayed asking "Do you need to specify an alternate source path?...". If the target machine does not have access to Windows Update, click the Specify an alternate source path link to specify the path to the \sources\sxs folder on the installation media and click OK. After you have specified the alternate source, or if the target machine has access to Windows Update, click the X next to the warning, and then click Install.

Or, if you don't like a GUI there's always powershell; Install-WindowsFeature NET-Framework-Core -Source D:\sources\sxs

Of course then you have to remove the OS check from the Exchange installer ...