Here is a follow up...

Sometimes when I open IE9 32-bit from the task bar, a notification bar pops up at the bottom asking whether I want to make IE9 my default browser. The first time I saw it, I thought something changed my default setting from IE9 to something else, so I clicked Yes. Then I found out that IE9 64-bit became my default browser.

I had to manually change the program ascociations for "*.website" to "Internet Explorer" (even though it was already set to that), which reset it back to IE9 32-bit.