@Vaccano: If you stop assuming that 4.5 will fix bugs that won't be fixed in 4.0 then you can use VS2012.