@Minh:VLC works fine for me. Version 2.0.2. (now upgraded to 2.0.4)