, magicalclick wrote

If you are annoyed by sites that gives you IE6 pages. Press F12 and set the browser mode to IE9, so the sites will serve you IE9 pages.

I don't know if IE10 works the same as IE9 (I'm not running Win8) but with IE9 I found the better solution to be disabling all of the compatibility options, and in particular, disable the 'Use list from Microsoft' option, as they always seem to force the browser into the wrong mode.