After investigating a little, it seems the requests to your servers are being stopped by our proxy server authentication. Even though Visual Studio uses default proxy settings to make connections, it seems extensions don't by default.

I don't think this is difficult to add in a config file. See for example

http://stackoverflow.com/a/2131963/817630

But I don't know of a way I can enable it. Could you update the extension to use the system default proxy settings? Or recommend changes to allow this?