Maybe I'm stating the obvious... did you enable SQL security on your SQLServer?