Doesn't mean I have to like it Smiley

It's not so bad when the resulting name still makes sense, here I don't think it does but then I'm not keen on WebRequest as a name anyway. And there are certainly counter-examples already; you get a DivideByZeroException rather than a DivideByZeroArithmeticException, for example, and you tend to use Buttons rather than ButtonControlComponents.

I'd prefer a descriptive name over an unnecessary enumeration of class hierarchy every time.