AndyC said:
It's not NTFS, per se, it's the mechanism used to generate legacy 8.3 filenames that slows things down. If you know you're going to have folders containing more than about 300,000 files (and you aren't relying on 8.3 filenames) then it's recommended to turn off 8.3 filename generation(see: http://technet.microsoft.com/en-us/library/bb457112.aspx - scroll down to Optimizing NTFS Performance).

You can turn off short filename generation by using the command: fsutil behavior set disable8dot3
FANTASTIC! thanks so much Andy! that was exactly what the issue was. i was able to execute that command and my apps performance returned to exactly where it had been when it started (about 100X faster than where it had dropped to by the way).