jh71283 said:
dpratt71 said:
*snip*
I've temporarily switched it off entirely

bcdedit /set nx AlwaysOff
Bad move from a security point of view.

Are you sure you're getting the parameter types correct for the COM interop, and marshalling everything that's returned?