You will need the Enterprise edition or above to use some of the data tool features against SQL2k Enterprise. You will need MSDE. See:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconVisualDatabaseToolsEditions.asp

Also you cannot use another user's credentials when you choose Integrated Security. Windows integrated security essentially uses your current security identity/token.

Thanks.

MilindL