I have posted a reply on the MSDN Forums, the errors for the above are because you have both the 1.1 and the beta 2.0 assemblies referenced for the Managed DirectX systems. Make sure that you have only got the assemblies referenced with a version number starting with 1.x.

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=203954&SiteID=1&mode=1

The reason for this is that the new beta assemblies have all of the name spaces included for the managed directx systems. In the future this will assist with distributing your applications.