I won't detail the full problem here (read my blog entry for the full details http://blog.bartholomew.id.au/archive/2004/05/31/330.aspx) but is there a particular reason that Enterprise Manager always creates stored procedures with ANSI_NULLS set to OFF? This seems bizarre since it is not the default or recommended setting?