Actually it started playing for me if I login with remote desktop but set "Play on remote computer" remote connection audio setting (You'll find it when creating remote connection, click Options->Local Resources->Settings)

My exact error code was also 0xc00d11cd - 0x80004002