Is there any backwards compatibility here, or is 6.5 the end of that era? When will development kits be available for this?