I'm assuming from the rapid cut after "We're targeting IE 5.5/IE6" that Firefox/Opera support will be absent. Ah well, it could be the most amazing webmail system ever written by the hands of men or God, and now it seems I can't use it.