In any case, this is bad form. There was no benefit either performance-wise or laziness-wise and certainly not maintenance-wise. I had to change the code to call the generic overload of GetUserID() that returns a UserID based on int. Had the code been written to use a local variable, I would have needed to change one line of code instead of 4.
I see this kind of stuff so often, I often wonder if it's intentional or just due to laziness. I can understand not bothering with a local variable if a method is called only two times, but this one was ridiculous.