worth calling out that you have to be using version 1.3 of the Windows Azure SDK or newer for any virtual machines...