I will also have to agree with s_jetha and junior882 that it has to have firefox support. Keep up the good work and its looking pretty nice.