Angular JS: A fresh Breeze in the SPA

Sign in to queue

The Discussion

  • User profile image
    Asad

    Is source code available for this sessions?

  • User profile image
    LukePuplett

    This is a good demo, thanks Erwin. But I can't not say something about the bad naming in JavaScript though. What's the deal with bad names, even by programmers who choose good names in other languages??

    function dataservice() {}

    OR

    logger.info()

    Surely all function names must contain a verb? And abbreviated names like Ctrl instead of Controller. It drives me crazy.

    - Edit - 

    Actually, the dataservice name is arguably not a bad name since its kind of an object with functions.

Add Your 2 Cents