Coffeehouse Post

Single Post Permalink

View Thread: Automatic Updates Service not working... I am out of ideas
  • User profile image
    xyvyx

    danielsmith89 said:
    I am having this same problem too and am trying to delete all the wu*.* files, I manage to delete them fine, but they just recreate themselves straight away, do you know how i can stop this?

    Shining Arcanine wrote:
    Thanks cheong. I got around to deleting all of the wu*.* files from c:\windows today and went to Windows Update. I can now use Windows Update again. Microsoft Update and Automatic Update are working too.
    I had the same issue... I'd delete all of the wu*.* files in system32... and they'd pop right back up!.. Still no idea what caused this.  Regardless, I was primarily using the recent windowsupdateagent30-x86.exe to update, or at least attempt it.  This was returning the same errorcode as when visiting the Windows Update website.

    My last attempt, I used ProcMon & followed this process.... which itself created another process for RegSvr32... watching THAT, I could see all the files & registry keys it attempted to read/write/create.  I saw 2 failures when it attempted to create keys here:
    HKLM\Software\Microsoft\Windows NT\CurrentVersion\SvcHost

    This was mentioned elsewhere, but for me, resetting the permissions (at least, granting local admins full control) on this key solved my problem.  I'd since tried just about every permutaion of registering, unregistering DLLs, stopping & starting the services, etc... 

    I'm not sure if it's related, but we started seeing this issue quite a bit after we were affected by conficker.b, so I'm not sure if the worm caused issues, or if it was our cleanup efforts.  Either way, problem finally solved.  I'll test this on other servers & if other actions are required, I'll post 'em!