Coffeehouse Post

Single Post Permalink

View Thread: Automatic Updates Service not working... I am out of ideas
  • User profile image
    Shining Arcanine

    Cider wrote:
    

    Try registering the following (in this order):

    regsvr32.exe qmgr.dll

    regsvr32.exe qmgrprxy.dll


    If that still doesn't work, can you post any part of your C:\Windows\Windows Update.log which shows the error?



    I tried that earlier, I also tried unregistering them first but nothing I do with the dlls fixes the problem. Here is the latest from the WindowsUpdate.log file:

    2006-06-11    20:54:02    1108    874    Service    *************
    2006-06-11    20:54:02    1108    874    Service    ** START **  Service: Service startup
    2006-06-11    20:54:02    1108    874    Service    *********
    2006-06-11    20:54:02    1108    874    Setup    Registering binary: C:\WINDOWS\system32\regsvr32.exe  /s "C:\WINDOWS\system32\SoftwareDistribution\Setup\ServiceStartup\wuapi.dll\5.8.0.2469\wuapi.dll"
    2006-06-11    20:54:02    1108    874    Setup    Registering binary: C:\WINDOWS\system32\regsvr32.exe  /s "C:\WINDOWS\system32\SoftwareDistribution\Setup\ServiceStartup\wups.dll\5.8.0.2469\wups.dll"
    2006-06-11    20:54:02    1108    874    Setup    FATAL: Self registration of C:\WINDOWS\system32\SoftwareDistribution\Setup\ServiceStartup\wups.dll\5.8.0.2469\wups.dll failed, error = 0x8024D007
    2006-06-11    20:54:02    1108    874    Setup    FATAL: Failed to register C:\WINDOWS\system32\SoftwareDistribution\Setup\ServiceStartup\wups.dll\5.8.0.2469\wups.dll in cache location: error 0x8024d007
    2006-06-11    20:54:02    1108    874    Setup    FATAL: ProcessDelayedCopies failed: 0x8024d007
    2006-06-11    20:54:02    1108    874    Agent    FATAL: Failed to fix up registration at service startup: 0x8024d007
    2006-06-11    20:54:02    1108    874    Service    *********
    2006-06-11    20:54:02    1108    874    Service    **  END  **  Service: Service exit [Exit code = 0x8024d007]
    2006-06-11    20:54:02    1108    874    Service    *************
    2006-06-11    20:54:32    3208    3a8    Setup    FATAL: Warning: Failed to restart wuauserv service: 0x8007041d
    2006-06-11    20:54:32    3208    3a8    Setup      * WARNING: Exit code = 0x8007041D
    2006-06-11    20:54:32    3208    3a8    Setup    *********
    2006-06-11    20:54:32    3208    3a8    Setup    **  END  **  Setup: Installing client binaries
    2006-06-11    20:54:32    3208    3a8    Setup    *************
    2006-06-11    20:54:32    3208    3a8    Setup    FATAL: InstallUpdatedBinaries failed with error 0x8007041d
    2006-06-11    20:54:32    3208    3a8    WUWeb    FATAL: InstallUpdatedBinaries failed with error:0x8007041d
    2006-06-11    20:54:32    3208    3a8    WUWeb    FATAL: UpdateClientWorker failed: error 0x8007041d


    Edit: Before anyone mentions it, I am not running NOD32.