Coffeehouse Thread

26 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

Automatic Updates Service not working... I am out of ideas

Back to Forum: Coffeehouse
  • User profile image
    itsupport

    "HKLM\Software\Microsoft\Windows NT\CurrentVersion\SvcHost"

    Resettings perms fixed my probs.

    Nice one XYVYX, I've been working for a couple of weeks on a server that had this issue and have tried just about everything Google could turn up. Two days ago, a laptop starts having the same issue. I use WSUS so I had no idea windows updates were failing when going to the site.

  • User profile image
    ISingBass

    Great catch, xyvyx. This fixed my problem too. I just had to check the box to allow "full control" in permissions for the "HKLM\Software\Microsoft\Windows NT\CurrentVersion\SvcHost" registry key. Magic. Smiley

     

    Don't know what caused the problem in the first place. Network admins have been switching things around--maybe it's related.

     

    Thanks for the help.

  • User profile image
    forevernoob

    Thanks to everyone. I had the same problem, also with wups.dll as the culprit. After trying everything suggested here, I checked windows\system32\softwaredistribution\setup\servicestartup\wups.dll\ and found three versions. Deleted the latest-numbered subfolder; that did it. (I also deleted the latest version of wups2.dll, also in servicestartup, but will guess that didn't matter.)

  • User profile image
    Idellaj

    cheong said:
    From a cached webpage in Google (the page no longer exist, but still can be found in Google's cache) that you may want to try:

    [quote user=Google]
    Ok, I know I'm talking to myself here but maybe it will help someone else in
    the future so here goes...

    I didn't get to the root cause, but my system seems to be in working order
    now.

    When I first tried going to WindowsUpdate on this Win2K3 system I was
    getting the Time error described in another thread at
    http://support.microsoft.com/newsgroups/newsReader.aspx?dg=microsoft.public.windowsupdate&mid=2cdb89ef-21b9-469c-9cff-3252f78c84b6.
    Rather than troubleshooting that error I decided to go to the new Microsoft
    Update site and upgrade to the latest software instead. That's where the fun
    began and I started getting the errors I posted earlier.

    From there I tried removing the Program Files\Windows update folder and also
    the Windows\Sftware Distribution\WebSetup and WuReDir folders to no avail.
    The system would still keep re-directing to the MU v6 site and erroring at
    0x8024D007. Looking in the WindowsUpdate.log it appeared to be a problem
    registering wuaueng.dll but I was able to run the same command line manually
    without any problems. From the error it looked to be a possible Registry
    permissions error so I tried REGMON but wasn't able to narrow down any
    specific key with a problem.

    ***!!! FOLLOW THESE STEPS AT YOUR OWN RISK !!!***

    Finally, since this wasn't a production system I just removed all of the
    WU*.* files out of Windows\System32 and then went back to WindowsUpdate and
    it loaded up at v4 rather than re-directing me to the v6 site. Now I was
    back to the Time error from the thread linked above. Following the
    resolution in that thread (turning off the "Check for server certificate
    revocation) I was able to download all of the latest updates for my system
    and in the process the WindowsUpdate engine got successfully upgraded to v6.
    After all of the updates were applied I then went back to the new Microsoft
    Update site and everything is working as you'd expect it to even with the
    "Check for server certificate revocation" turned on.

    So there's my fun troubleshooting for the day. Hope it helps someone else
    and don't forget to backup any files before you delete them!

    -Jeff


    [quote user=Google]
    I'm telling you what I tried before I finally resolved the issue in case
    this contributes to the resolution. I would recommend trying the following
    and if it doesn't resolve the issue then try the others suggestions and then
    mine again.

    Okay it's very very simple. I checked the logs for windows update and it
    seemed to have a problem registering a DLL file in the c:\winnt\system32
    directory. (This may be c:\windows\system32 on WinXP). I loaded up a DOS box,
    (cmd box), and typed regsvr32 and then the dll file. Nothing happened. I
    then typed regsvr32 /? which should bring up the options. Again nothing
    happened. I suspected that the regsvr32.exe file may be corrupted.

    I downloaded a file called regsvr32a.exe from here:-

    http://support.microsoft.com/default.aspx?scid=kb;en-us;267279

    This is a self extractable file. I used my prefered method of downloading
    the file into an empty directory. Running the file and then manually copying
    the new regsvr32.exe into my SYSTEM32 directory. I then confirmed that I
    wanted to overwrite the existing version. I then rebooted just to keep
    things clean and hey presto everything worked again.

    I hope this is of some help to somebody. I know I've probably done an
    overkill on the details but hopefully this will help people of all levels.

    Regards

    felixkat
    [/quote]
    [/quote]

    I had the same problem.  The solution you suggested worked perfectly

  • User profile image
    DinK7

    I had to sign in to give a big THANKS to you guys in this thread, especially a couple of the older posts.  I've been researching and trying all kinds of crazy stuff because Microsoft Security Essentials wouldn't update on one of my PCs. (worked fine on other PCs on the same connection, all runing XP)  I eventually narrowed it down to the Automatic Updates service not working at all.  I couldn't get it to work after registering dlls or trying utilities to fix it.  I tried the approach mentioned earlier in this thread of deleting wu*.* in system32 and dllcache and it's fixed!  MSE immediately started updating before I even checked it.

  • User profile image
    golnazal

    open thread.

  • User profile image
    GoddersUK

    Which is weird because on page 1 it does say that the thread is closed...

  • User profile image
    cw1972

    just to confirm, moving the wu* files out of \system32 worked for me

    I went back to Windows update, it reinstalled some activex stuff then asked me to reboot

    upon restart the Automatic Updates service started normally and I was able to use the Windows Update service again

    thanks everyone in this thread

    I only have a few more services to fix now

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.