Coffeehouse Thread

9 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

ATTN: JSamsponPC

Back to Forum: Coffeehouse
  • User profile image
    W3bbo

    Time for karmic retribution.

    I've got a massive PHP problem that shouldn't take more than 5 minutes to fix, you're a self-proclaimed expert in the field, so why not help out a fellow self-proclaimed APS.NET expert? Wink

    The problem's with getting IIS to work with PHP, I keep getting "No input file specified." messages (with the ISAPI, PHP v4.4.4), when I switch to CGI I get "The specified CGI
    application misbehaved by not returning a complete set of HTTP Headers", I've followed the Windows installation instructions verbatim (well, so that they apply for IIS6, the instructions were written for IIS4 which has a somewhat different application model)

    What's your MSN Msgr address?

  • User profile image
    Rossj

    Change the doc_root in the php.ini to the web root folder..Perplexed

  • User profile image
    W3bbo

    Rossj wrote:
    Change the doc_root in the php.ini to the web root folder..


    As I said, I'm not running the CGI version, I'm running the ISAPI version. The doc_root property only applies to the CGI version.

    BTW Ross, what times are you on jabber?

  • User profile image
    Rossj

    W3bbo wrote:
    
    Rossj wrote:Change the doc_root in the php.ini to the web root folder..


    As I said, I'm not running the CGI version, I'm running the ISAPI version. The doc_root property only applies to the CGI version.


    It applies to both, the one in your c:\windows folder.

    W3bbo wrote:
    
    BTW Ross, what times are you on jabber?


    Normally at night, during work I am only on MSN .. and No.

  • User profile image
    W3bbo

    Rossj wrote:
    
    W3bbo wrote:
    Rossj wrote:Change the doc_root in the php.ini to the web root folder..


    As I said, I'm not running the CGI version, I'm running the ISAPI version. The doc_root property only applies to the CGI version.


    It applies to both, the one in your c:\windows folder.


    Nope Smiley

    Anyway, I've got my PHP4 installation now working flawlessly, after accidentally disabling 90% of all the other services by accident (I unchecked "Read" oo-er!)

    Rossj wrote:
    
    W3bbo wrote:
    BTW Ross, what times are you on jabber?


    Normally at night, during work I am only on MSN .. and No.


    Acknowledged.

  • User profile image
    Rossj

    W3bbo wrote:
    
    Rossj wrote:
    W3bbo wrote:
    Rossj wrote:Change the doc_root in the php.ini to the web root folder..


    As I said, I'm not running the CGI version, I'm running the ISAPI version. The doc_root property only applies to the CGI version.


    It applies to both, the one in your c:\windows folder.


    Nope



    How then do you tell it which extensions to load?

  • User profile image
    W3bbo

    Rossj wrote:
    
    W3bbo wrote:
    Rossj wrote:
    W3bbo wrote:
    Rossj wrote:Change the doc_root in the php.ini to the web root folder..


    As I said, I'm not running the CGI version, I'm running the ISAPI version. The doc_root property only applies to the CGI version.


    It applies to both, the one in your c:\windows folder.


    Nope



    How then do you tell it which extensions to load?


    From php.ini in C:\PHP

  • User profile image
    Rossj

    W3bbo wrote:
    



    From php.ini in C:\PHP


    Ah. The docs suggest moving it, and I thought maybe you might have read them Wink

  • User profile image
    W3bbo

    Rossj wrote:
    
    W3bbo wrote:



    From php.ini in C:\PHP


    Ah. The docs suggest moving it, and I thought maybe you might have read them


    The docs say you can move php.ini to C:\Windows, but they recommend you keep them all in C:\PHP and add "C:\PHP" to the PATH environment var.

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.