Coffeehouse Thread

52 posts

VS2005 SP1 BETA available; your experiences?

Back to Forum: Coffeehouse
  • User profile image
    Sven Groot

    Me as well.

  • User profile image
    PeterF

    Count me in too

  • User profile image
    littleguru

    The download is available now. I'm downloading. It is 367 MB.

  • User profile image
    Sven Groot

    Installing now...

    EDIT: It's been busy for over five minutes, and only now it asks me if I want to install. Too slow, people, way too slow.

    EDIT2: It's already taking longer than it took to install VS2005 to begin with, and it's still "Gathering required information..." This had better improve immensely before release.

  • User profile image
    Sven Groot

    I'm still installing. Now more than 30 minutes, still stuck at "Gathering required information"

  • User profile image
    littleguru

    It is really slow. It takes a lot CPU and does a lot before actually starting to install. I guess it has to inspect all the packages installed. Visual Studio is a complex piece of software.

    After the installation everything seems to run very fine. I haven't found any problem yet.

    Edit: One problem found. Can't compile without opening a file of the solution. Weird: sometimes I don't need to open one sometimes i need.

  • User profile image
    littleguru

    Sven Groot wrote:
    I'm still installing. Now more than 30 minutes, still stuck at "Gathering required information"


    I can't tell you exactly how long mine took. I was out for lunch. But it took approx. 20 minutes! I have Team Suite and quite everything installed (no Crystal Reports).

  • User profile image
    Sven Groot

    Coming up on 45 minutes, still "Gathering required information". I'm using Vista 5728, maybe that has something to do with it.

  • User profile image
    Sven Groot

    Oh, that's just great.

    It finally got beyond the "Gathering required information" stage, proceeded to install which seemed to go a bit faster at least. After about two minutes the progress bar is all the way at the end, and I get an error that it can't open C:\Program Files (x86)\Microsoft Visual Studio 8\SDK\v2.0\Bin\sdkvars.bat for writing. Retry fails so I can only pick Cancel, so now it's rolling back.

    Nearly an hour wasted and installation failed. Could just be my comeuppance for doing beta-on-beta, but I'm still not happy.

  • User profile image
    littleguru

    I've disabled UAC in Vista (running build 5600 aka RC1). Perhaps that is making the difference?

    Control Panel -> User Accounts and Family Safety -> User Accounts -> Turn User Account Control on or off

  • User profile image
    Sven Groot

    I don't want to turn UAC off. I run as a limited user (just like I did in XP) and UAC makes life a gazillion times easier for limited users.

    Anyway I elevated the installation manually this time using right-click, run as administrator instead of waiting for Windows Installer to ask me and it worked this time. Still took way too long though.

    One new thing is a message at startup that running Visual Studio without administrator rights on Vista isn't supported. Which is weird, since it works fine for me. Fortunately the message can be disabled.

    It's good to see that Microsoft is finally realizing how important it is to get developers to run as limited users so they develop software that works with limited rights, and that they're doing everything to make using their development tools under limited accounts as painless as possible. </sarcasm>

  • User profile image
    littleguru

    I have it turned off, as it is giving me problems with a few old apps. Anyway, asap those are fixed i will it turn on again Smiley

  • User profile image
    Cannot​Resolve​Symbol

    Running SP1 in Visual C# EE...  although I never saw most of the issues many people have seen (because I'm not a professional developer), it does look like they've gotten rid of some of their performance bottlenecks--  the designer seems to load a lot faster.  Help still takes forever to load, though.

    Now to install it in MSVC++ and hope that it doesn't break the changes you have to make to use the Platform SDK in it.

  • User profile image
    Pace

    those who have installed, can you provide more feedback?

  • User profile image
    littleguru

    Pace wrote:
    those who have installed, can you provide more feedback?


    It seems to be quite nice. VS is a lot faster here... It is still taking a lot of RAM, but it's lot faster. The designer seems to be faster aswell: I was astonished how fast forms open.

    But it has still a few problems, but those could be design issues, which are not gone with the SP1.

    The clean solution, restart, rebuild problem seems to be gone! At least here.

  • User profile image
    dahat

    Any chance someone knows where a change log can be found?

  • User profile image
    NuTcAsE

    Does any one know where the newsgroup for the VS 2005 Beta 1 SP1 is? Can't find it on connect.... or is there one?

    Thanks.

    [Edit: Fixed typos]

  • User profile image
    PerfectPhase

    My install onto XP-SP2 ran through the install really fast seemed to go fine, tells me it's installed, click OK to that message then the installer starts all over again and hangs on 'gathering information', cancel that after about half hour and now I'm not sure what state it's in!

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.