Coffeehouse Thread

47 posts

I hate Vista's Windows Explorer! [help required]

Back to Forum: Coffeehouse
  • User profile image
    littleguru

    Why, oh why! I can't select more then one file in Vista's Windows Explorer - it's not important which view I select. And the "order columns" are missing in most of the views (see red box)...

    Next UAC takes like hours when I try to open OrcasBeta1VSTS_VPC_8PartsTotal.part01.exe (the first file of the Orcas Beta 1 SFX RAR archive) -- it is 700 MB, but why does UAC take that long? CPU doesn't even go up... Looks like a bug to me! I have no AV installed!

    Screenshot:



    It's driving me nuts!


    Edit: If I hold down the left mouse button (mouse down event) somewhere (in an empty place in the Windows Explorer) and move it around the so called "selection rectangle" (this semi-transparent blue thing) doesn't show up anymore!

    Somebody from the Windows Shell team here?

    Edit 2: I have seen that a lot of other people have the same problem! There is one solution, but that doesn't work with me. Others are complaining that this fix doesn't work for them too. The fix works only for the first folder I open. If I switch to another folder the problem comes back: it seems as if the settings are corrupt and when opening the second folder the corrupt settings are going to be used again.

    This would be the solution (the one that works only for the first folder I open):

    1. Open Regedit
    2. Navigate to HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\
    3. Delete the Bags & BagMRU keys


    Links to articles on the problem (they always have the same solution - the one that doesn't work):

    http://serena-yeoh.blogspot.com/2007/01/cannotselectmultiplefiles.html
    http://www.jkg.in/120-unable-to-select-multiple-files-in-windows-explorer.htm
    http://www.winforumz.com/vista/Explorer-multiple-select-working-Vista-ftopict13845.html

  • User profile image
    k2t0f12d

    littleguru wrote:
    Why, oh why! I can't select more then one file in the Vista Explorer - it's not important which view i select. And the order columns are missing in most of the views...

    Next UAC takes like hours when I try to open OrcasBeta1VSTS_VPC_8PartsTotal.part01.exe - it is 700 MB of size, but why does UAC take that long? Looks like a bug to me!

    Screenshot:



    It's driving me nuts!


    Now now, no complaining.  Everybody had the chance to make Vista better while it was in betas. Tongue Out

  • User profile image
    littleguru

    k2t0f12d wrote:
    Now now, no complaining.  Everybody had the chance to make Vista better while it was in betas.


    I told them about this bug!! I even posted it here. And it was said to be a Beta bug... But it seems to persist! I have it since a few days (week) now.

  • User profile image
    jamie

    k2t0f12d wrote:
    

    Now now, no complaining.  Everybody had the chance to make Vista better while it was in betas.



    ...and everybody...DID  :O

  • User profile image
    Lloyd_Humph

    Im sure theres a way to change the selection box thingy in XP.Theres a control in Option somewhere (ive either seen in in XP or 2000) that allows you to turn on/off. I cant find it so maybe its only in 2000... Perplexed

    Try find it. Might help?

    If Blackberrys are addictive cellphones, Channel9 is the ultimate addictive website.
    Last modified
  • User profile image
    mig

    Heh, I crash Vista's Windows Explorer on a daily basis, I actually crashed it like 10 times renaming folders the day before yesterday (there were ALOT of folders involved). I will say the Tab while in F2 mode is GREAT but those little details should be there with a working Explorer as well! Let's hope SP1 fixes most of these kinks. I also wonder what happened to the common tasks like "Copy To, Move To, Delete File/Folder" etc., they're gone from the toolbar now!

  • User profile image
    Royal​Schrubber

    Does it happen in every folder? Every drive? Tongue Out Try to close different UI elements, or even indexing.  

  • User profile image
    DCMonkey

    I filed a bug in Beta on that mouse selection thing too. Specifically, I have a problem with the whole row in details vew being selectable now. I'm sorry MS, but 16 years of rubber-band selecting of files is hard to unlearn. I'd love to see the user testing that shows how clicking in empty white space (especially between file names and the next column over) is more intuitive. To me it just irritates to no end and increases the chance for "Oh sh*t where'd my files go now?!?" moments. Thumbs down on that particular innovation.

  • User profile image
    Koogle

    "Next UAC takes like hours when I try to open OrcasBeta1VSTS_VPC_8PartsTotal.part01.exe (the first file of the Orcas Beta 1 SFX RAR archive) -- it is 700 MB, but why does UAC take that long? CPU doesn't even go up... Looks like a bug to me! I have no AV installed!..."


    I'm  pretty sure it takes ages because winrar has to check for all connected archives to the one you're opening ..  The same thing on an xp machine, trying to open a large winrar compressed archive, cpu load is pretty much stays around 1-4%, extracting uses as much cpu as possible ... so its more to do with hard drive performance, the less read/writes to the disk the faster it will be at opening the archive up.

    Still Vista explorer does suck, gotta wonder what all those 1000's of beta testers contributed in useful suggestions to the MS teams on Vista's development, or maybe no one was listening..  dunno but i'm still preferring my xp explorer window with addons better.



  • User profile image
    ZippyV

    Why is UAC even involved in this? You shouldn't see the prompt if you just have to unzip it.

    I prefer 7-zip for compression/decompression. It can also handle rar and iso.

  • User profile image
    littleguru

    Koogle wrote:
    I'm  pretty sure it takes ages because winrar has to check for all connected archives to the one you're opening ..  The same thing on an xp machine, trying to open a large winrar compressed archive, cpu load is pretty much stays around 1-4%, extracting uses as much cpu as possible ... so its more to do with hard drive performance, the less read/writes to the disk the faster it will be at opening the archive up.


    After disabling the UAC the file gets extracted as I click it!

  • User profile image
    littleguru

    RoyalSchrubber wrote:
    Does it happen in every folder? Every drive? Try to close different UI elements, or even indexing.  


    Every drive! Everywhere! Even when browsing the Windows Mobile phone via explorer.

  • User profile image
    Lloyd_Humph

    Koogle what are those icons next to the control box? (x _ [_]) also the calc? Never seen them before... would be interesting to accquire :

    Lloyd)

    If Blackberrys are addictive cellphones, Channel9 is the ultimate addictive website.
    Last modified
  • User profile image
    Rowan

    I'm happy with the changes to Explorer, however, how can I set a default view for other applications that use Explorer? Example, while browsing to a location using Photoshop (File > Open...), every folder will default to a 'list' view. Changing the view to 'details' will be remembered, but the next folder will be back to the 'list' view again.

    Any ideas?

  • User profile image
    YearOfThe​LinuxDesktop

    littleguru wrote:
    Next UAC takes like hours when I try to open OrcasBeta1VSTS_VPC_8PartsTotal.part01.exe (the first file of the Orcas Beta 1 SFX RAR archive) -- it is 700 MB, but why does UAC take that long? CPU doesn't even go up... Looks like a bug to me! I have no AV installed!


    I believe explorer checks every single executable before executing it (I think it searchs for a digital signature).

  • User profile image
    YearOfThe​LinuxDesktop

    I just discovered I can't select files too in certain folders like for example c:\windows\system32\ . can somebody try to see if select works in that folder?

  • User profile image
    Secret​Software

    Make folder view detailed list. easier to select stuff.

  • User profile image
    littleguru

    YearOfTheLinuxDesktop wrote:
    I just discovered I can't select files too in certain folders like for example c:\windows\system32\ . can somebody try to see if select works in that folder?


    Started the same here. First only in some folders, now in all.

    And there is no pill to cure it... I tried to reset the folder views etc. But nothing seems to work Sad

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.