Coffeehouse Thread

12 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

msExchMasterAccountSID, how I hate thee

Back to Forum: Coffeehouse
  • User profile image
    Cairo

    Apparently disabling an account in Exchange/AD is a one-way affair; once the account is disabled, the Information Store disallows any access ti the mailbox, even after the account is reenabled.

    I hate Exchange.


  • User profile image
    manickernel

    Go to esm and reconnect the mailbox.

  • User profile image
    Cairo

    Option greyed out.

  • User profile image
    stg

    Try the following: In 'User Manager for Domains' ensure that in 'Mailbox Rights' on the property page for the re-enabled account the 'self' user has 'Associated external Account' checked.

    if there is no 'Associated external Account' then Exchange doesn't work.


    My current favourite Exchange issue is that since SP1 whenever you send a signed mail in Outlook all the mail gets jammed in the Pending queue. There is a MS hotfix available for this from MS Support but I am a bit loathed to install it on a live server; it's less hassle just to tell everybody not to sign mails.





     

  • User profile image
    Steve411

    Re-install Exchange.

  • User profile image
    manickernel

    I had the issue with grayed out reconnects on disabled accounts, and it also would not allow me to purge. Solution was to rerun setup /domainprep. Somehow permissions were not right after upgrade to 2003 exchange.

    It takes about 30 seconds, and I did not have to shutdown exchange.

  • User profile image
    Cairo

    manickernel wrote:
    I had the issue with grayed out reconnects on disabled accounts, and it also would not allow me to purge. Solution was to rerun setup /domainprep. Somehow permissions were not right after upgrade to 2003 exchange.

    It takes about 30 seconds, and I did not have to shutdown exchange.


    Thanks, I'll look into that.

  • User profile image
    Larry​Osterman

    Cairo wrote:
    Apparently disabling an account in Exchange/AD is a one-way affair; once the account is disabled, the Information Store disallows any access ti the mailbox, even after the account is reenabled.

    I hate Exchange.



    Hey, msExchMasterAccountSID was MY idea Smiley

    It solves a hideously nasty problem in Exch5->Exch2K migration.

  • User profile image
    Maurits

    Certainly msExchMasterAccountSID has saved me many a time.
    But I'd rather it just work.  Can't you have it automatically be SELF for all mailbox-enabled user accounts?

  • User profile image
    Cairo

    LarryOsterman wrote:
    Cairo wrote:Apparently disabling an account in Exchange/AD is a one-way affair; once the account is disabled, the Information Store disallows any access ti the mailbox, even after the account is reenabled.

    I hate Exchange.



    Hey, msExchMasterAccountSID was MY idea

    It solves a hideously nasty problem in Exch5->Exch2K migration.


    Well, after days and days of trying stuff, knowledge base articles that didn't work, etc., we have managed to re-enable access to that mailbox. Just enabling the account doesn't appear to work. The voodoo seemed to involve:
    1. Disable account.
    2. Remove all non-inherited accounts from the security settings for the mailbox ("Exchange Advanced").
    3. Re-enable the account.
    4. Change the account password.
    5. Make "SELF" the external account, full access, etc. apply/ok/ok/apply/ok
    6. Edit account again, add back accounts that should have access.
    7. Wait.
    8. Try to access it.
    9. Wait.
    10. Try to access it.
    11. Wait.
    12. Try to access it.
    13. Success. 


  • User profile image
    Cairo

    Steve411 wrote:
    Re-install Exchange.

    The image “<a href=http://www.mcclave.com/puke/images/puke_man.gif” cannot be displayed, because it contains errors." src="http://www.mcclave.com/puke/images/puke_man.gif">


  • User profile image
    manickernel

    Oh, I suppose I should mention I *think* that in my  case I shot myself in the foot by running:

    dsacls /S /T

    ...so few letters...so much power.
    I guess default means default BEFORE Exchange was installed.
    Wink

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.