Coffeehouse Thread

4 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

SQL Server Enterprise Manager Error

Back to Forum: Coffeehouse
  • User profile image
    VBJB

    I am getting an error after upgrading to SP1 on my SBS 2003 (only thing that has changed).

    Reproduce:
    -Open up SQL Server Enterprise manager
    -Navigate to the database of interest
    -Right click on the node and go to properties to get database size

    Once, I do this, the MMC disappears and this error is generated.

    Faulting application mmc.exe, version 5.2.3790.1830, faulting module sqldmo.dll, version 2000.80.194.0, fault address 0x0007b7ab.

    any thoughts?

  • User profile image
    Mike Dimmick

    Don't upgrade to Windows Server 2003 SP1 on SBS 2003. Yes, I know, it's too late. Do a search to see if there's a way to unpick the mess.

    Secondly, you should have upgraded your SQL Server to Service Pack 3(a), then applied the MS03-031 patch. After this you should apply the KB826161 patch, which fixes a problem where you're always asked for a new password when changing other properties of a SQL Server login.

    I know you haven't done this because the reported version of sqldmo.dll is from the RTM version, no service packs applied.

    I don't know that upgrading to the latest service pack will help, but you should definitely do so. If I'm right, you're still vulnerable to the Slammer worm.

  • User profile image
    VBJB

    From my preliminary search my system is up to date.

    My version is consistent with SP3a = 8.00.761 and my version of my ssnetlib.dll = 2000.80.766.0 for SP3a (see this).

    Any thoughts

  • User profile image
    a222493

    I am getting the same error.  Has anyone solved this?

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.