Coffeehouse Thread

13 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

Gah - they've broken (changed) some features I like in Windows 8.1 :(

Back to Forum: Coffeehouse
  • User profile image
    OrigamiCar

    Just wanted to check in with others who are using Windows 8.1 with multiple monitors to see if they experience the same thing or if it's just me.

    Like a lot of developers, I run Windows with multiple monitors (I use three monitors). With windows 8, I could press the windows key on my keyboard to quickly glance at the live tiles on my start screen and could quickly dismiss it by clicking anywhere on either of the two monitors that are showing either the desktop or desktop apps. This was just a handy little tweak that let me quickly dismiss the start screen.

    With Windows 8.1, clicking the desktop or desktop apps doesn't dismiss the start screen at all - it remains in place. The only way to dismiss it is to either click on a tile to start an app, or to hit the windows key again.

     

    The other behavior change is one of my monitors is a touch screen, but it's not my main monitor. With 8.0, I could start a windows 8 app, drag it to the touchscreen, close it and from that point onward, the start screen would always appear on the touchscreen, even though it's not my main monitor. With 8.1, even if I do that, the second I hit the windows key, it will appear on the main (non touchscreen) monitor. I can fix it by telling Windows that my touchscreen is my main monitor, but that causes the task bar, pinned icons etc to now be on my left monitor not on the middle monitor where I usually keep them.
    I read a webpage that said if you click the start button on the monitor you want to open the start screen, then from that point onward the start screen would always open on that screen, but that's not been my experience, it always reopens on the main monitor...

    Just to be clear, neither of these issues are world changing problems and I can live with them, but it would be nice to be able to get 8.1 running the way that muscle memory told me 8.0 ran for months Smiley

    Anyone else having this happen, or is your experience different?

     

    Richard.

     

  • User profile image
    Blue Ink

    @OrigamiCar: I see the same behavior. You can get the start screen to appear on any monitor, but once you dismiss it, the Win key will always make it appear on the primary monitor.

    This isn't a big deal for me: I have two monitors and I set one to be my "desktop monitor" (not the primary screen) while the other is mostly dedicated to outlook and modern apps (the primary screen). In this setup, not being able to dismiss the start screen accidentally by clicking on the desktop is an improvement IMO.

    Also, I replicated the taskbar on all the monitors: looks busier, but it's convenient enough that I don't mind the wasted pixels. This also has the added bonus that it's really easy to get the start screen to appear on any given monitor: I just have to click on the corresponding start button (hey, it's actually useful!).

  • User profile image
    GoddersUK

    , OrigamiCar wrote

    The other behavior change is one of my monitors is a touch screen, but it's not my main monitor. With 8.0, I could start a windows 8 app, drag it to the touchscreen, close it and from that point onward, the start screen would always appear on the touchscreen, even though it's not my main monitor. With 8.1, even if I do that, the second I hit the windows key, it will appear on the main (non touchscreen) monitor. I can fix it by telling Windows that my touchscreen is my main monitor, but that causes the task bar, pinned icons etc to now be on my left monitor not on the middle monitor where I usually keep them.

    Windows Logo + Page Down Smiley

  • User profile image
    MasterPi

    , OrigamiCar wrote

    With Windows 8.1, clicking the desktop or desktop apps doesn't dismiss the start screen at all - it remains in place. The only way to dismiss it is to either click on a tile to start an app, or to hit the windows key again.

    I haven't tried it with a multimonitor setup, but I had hoped they would implement this behavior (although, as an option of course). It basically reinforces the start screen as a launcher. So, you can just keep opening up desktop applications from the screen without it disappearing?

  • User profile image
    OrigamiCar

    , GoddersUK wrote

    *snip*

    Windows Logo + Page Down Smiley

    Sorry - is that supposed to do something? Doesn't seem to do anything on my machine... Perplexed

  • User profile image
    GoddersUK

    @OrigamiCar: If you do it with the start screen open it should move to the next monitor. On Windows 8 at least...

    EDIT:

    aha:

     

  • User profile image
    OrigamiCar

    , Blue Ink wrote

    @OrigamiCar:

    Also, I replicated the taskbar on all the monitors: looks busier, but it's convenient enough that I don't mind the wasted pixels. This also has the added bonus that it's really easy to get the start screen to appear on any given monitor: I just have to click on the corresponding start button (hey, it's actually useful!).

    Yeah agreed, that is very useful.
    In my case, I do have the taskbar is on all monitors, but I have set it to only show the taskbar buttons on the taskbar where the window is open (I tend to have a lot of instances of different visual studios, plus quite a few other apps open, so this way is much easier to keep track of what's open where). Having it set this way means that my pinned icons only show on the primary screen which is now the wrong screen - but it's not a biggie, my muscle memory is already starting to switch to the new setup. Smiley

  • User profile image
    magicalclick

    @OrigamiCar:

    You can do either Always Show Start Screen in Main Monitor or Show Start Screen in Currently Active Monitor in the usual taskbar property dialog.

     

    And I can click on other monitors task icon to open the app in the correct monitor (where it last closed) with auto start screen disappear.

    Leaving WM on 5/2018 if no apps, no dedicated billboards where I drive, no Store name.
    Last modified
  • User profile image
    Craig_​Matthews

    , OrigamiCar wrote

    I can fix it by telling Windows that my touchscreen is my main monitor, but that causes the task bar, pinned icons etc to now be on my left monitor not on the middle monitor where I usually keep them.

    On Windows 7, I can drag the taskbar to the bottom of any monitor I want regardless of which is set as the "main" one. Is that gone?

  • User profile image
    eddwo

    I kind of miss the 'Search Contract' thing, start searching from the charm bar and then choose the app to get the search results from. Can't really understand why that was removed, as it makes the experience less well-integrated, which seems like a step backwards rather than forwards.

    Otherwise my Surface RT upgraded itself to 8.1 fine, and still seems to have 'teh snappy', or 'fast and fluid' if you prefer. I haven't tried to use the new Outlook much yet.

    It took me a while to find the 'All Apps' view, and new app installs from the store don't show up as pinned tiles, so they seemed to just disappear.  I kind of miss the old Bing search app too, if only for it's nice selection of alternative lock screen images.

  • User profile image
    cbae

    With Windows 8.1, clicking the desktop or desktop apps doesn't dismiss the start screen at all - it remains in place. The only way to dismiss it is to either click on a tile to start an app, or to hit the windows key again.

    Esc key works great for this purpose. So does clicking the start button (again).

    The other behavior change is one of my monitors is a touch screen, but it's not my main monitor. With 8.0, I could start a windows 8 app, drag it to the touchscreen, close it and from that point onward, the start screen would always appear on the touchscreen, even though it's not my main monitor.

    There's a setting in "Taskbar and Navigation properties" that reads:

    "Show Start on the display I'm using when I press the Windows logo key"

    If you have this setting checked, all you have to do is move your mouse over to the correct display and click somewhere prior to pressing the Windows logo key.

  • User profile image
    Ghozer

    I haven't read all replies, however.....

    You can resolve the "Start" issue, by changing the option in the Taskbar properties... like said above...

    The other issue you have I also noticed, and have not yet found a way around it..

    I also have another issue I cannot seem to find anywhere...

    i'm running two monitors, with the task bar on each, and each monitor(s) programs or apps on the correct taskbar...

    Now, when I run a full screen app (like a video in GOMPlayer, or VLC as an example) but then want to view that monitors taskbar, I used to be able to click the bar on my OTHER monitor, and it would then bring the taskbar(s) to the front, and show them both, this no longer happens, and it's VERY annoying when i'm doing something full screen, and wish to use the taskbar buttons to switch to an open program on that monitor (as it's only a couple of clicks, as opposed to ALT+TAB or similar, which can mean me cycling through 8, or more windows to get to the one I want...)

    I haven't been able to find a way round this one yet... it's as though the taskbar's "Always on top" option has disappeared, but I don't want it ALWAYS on top, I just want it to come to the front when I click EITHER taskbar...

  • User profile image
    robkassab

    This may be helpful, as it was for me:  

    Issue: A customer connects a second Touch Display to a Touch based Laptop OR a Desktop already with a Touch Display.

    Symptom: Touch Displays are shipped with USB Cables. When both USB cables are connected to the computer, the operating system sees two displays and two touch panels. But, not necessarily associated with the displays that they are integrated on. Hence the touch functionality may not work as designed.

    Solution:
    * Ensure that the Secondary Display is in Extended Mode
    * To select Extended Mode, press the Windows Key + P  
    * In Desktop Mode, select Charms (Windows + C), choose Settings and then Control Panel  
    * Select View by Large Icons, choose Tablet PC Settings and select Setup 
    * Both screens will be a white background and the Primary Display will show the text:
    "Touch this screen to identify it as the touchscreen"
    "If this is not the Tablet PC screen, press Enter to move to the next screen."
    To close the tool, press Esc 
    * Touch the Primary Display once 
    * You will see a white screen with the following instruction:
    "Press Enter to proceed to the next step to complete your configuration" 
    * Press Enter to synchronize touch with the Primary Display
    * Touch the Secondary Display once 
    * You will see a white screen with the following instruction:
    "Press Enter to proceed to the next step to complete your configuration" 
    * Press Enter to synchronize touch with the Secondary Display

     

     

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.