Did you try using the "Internet Explorer (no add-ons)" option, and if so what was the result?