Try disabling the Compatibility View settings, particularly the 'Include updated website lists from Microsoft'

In my experience, these settings (particularly the list) forces sites into quirks mode that really don't  need to be.