Coffeehouse Thread

14 posts

Setting IE9 32-bit as default browser (as opposed to IE9 64-bit)

Back to Forum: Coffeehouse
  • BitFlipper

    I upgraded from IE9 Beta to IE9 RTM/RTW, and I noticed that if I click on the IE link on the task bar, it brings up IE9 32-bit. But if I drag/drop a link from the address bar onto the desktop and then click on it, it starts up IE9 64-bit.

    The "Set Default Programs" control panel only gives me an option for "Internet Explorer". How do I fix it so it always opens IE9 32-bit? I can manually go and explicitly select the IE9 32-bit executable for each extension but that would take quite some time.

    Any ideas?

  • magicalclick

    added question. how do you check 32bits? I check my about IE, but, it only say sipher length and blah. It is ending with version 16413.

    Leaving WM on 5/2018 if no apps, no dedicated billboards where I drive, no Store name.
    Last modified
  • Blue Ink

    @BitFlipper: Cannot reproduce the issue on my machine. It's always the 32 bit version that pops up.

    @magicalclick: the 64 bit version shows a "64-bit Edition" after the version number. Nothing appears on the 32 bit one.

  • intelman

    32bit is my default as well. How you got 64bit to be default is quite weird.

  • BitFlipper

    Yes I don't know how it got to be the default since I never changed it myself. All I did was upgrade from RC to RTM/RTW.

    And to check 32-bit vs 64-bit, open Task Manager and look for "iexplore.exe". For 32-bit, it is "iexplore.exe *32", and for 64-bit it is just "iexplore.exe".

    I first noticed there was a problem when the tabs appeared to the right of the address bar. I specifically set them to be below the address bar, but it seems that setting isn't propagated to the 64-bit version. So it is easy for me to tell when it is the 32-bit or 64-bit version.

    Did anyone try to drag a shortcut to the desktop and launch IE9 from that? Because as I said when launched from the task bar, it is indeed the 32-bit version, but when launched from a desktop shortcut, it is the 64-bit version.

  • BitFlipper

    OK I narrowed down the problem, and found a fix...

    What I did was uninstall IE9, which reverted back to IE8. I then tried to open the shortcuts on my desktop, and noticed that there wasn't any application ascociated with the shortcut. Turns out the shortcut has a "website" extension as opposed to "html" or similar. IE8 doesn't understand "website" extensions.

    So I re-installed IE9 and once again the links opened IE9 64-bit. I then went into the control panel to change file associations, found the "website" extension and simply re-selected Internet Explorer as the app to use. This time the links open IE9 32-bit.

    Is this a bug in the IE9 installer, or just some weird glitch on my system? Not sure.

  • BitFlipper

    Here is a follow up...

    Sometimes when I open IE9 32-bit from the task bar, a notification bar pops up at the bottom asking whether I want to make IE9 my default browser. The first time I saw it, I thought something changed my default setting from IE9 to something else, so I clicked Yes. Then I found out that IE9 64-bit became my default browser.

    I had to manually change the program ascociations for "*.website" to "Internet Explorer" (even though it was already set to that), which reset it back to IE9 32-bit.

  • Bobzilla

    I have Win 7 with both IE 8 (32-bit & 64-bit) installed. Will one install of the IE9 install both 32-bit and 64-bit in one process or will IE9 32-bit and 64-bit need to be installed in two seperate installs?

     

  • BitFlipper

    , Bobzilla wrote

    I have Win 7 with both IE 8 (32-bit & 64-bit) installed. Will one install of the IE9 install both 32-bit and 64-bit in one process or will IE9 32-bit and 64-bit need to be installed in two seperate installs? 

    My experience is that you will not be able to choose the 32-bit version at installation (it tells you that you must use the 64-bit version instead). The 64-bit installer will then install both the 32-bit and 64-bit version and will then set the 32-bit version as the default.

    However, note the issue/bug I'm running into where it then afterwards wants to change the default to the 64-bit version. I can't believe I'm the only one running into this issue. My system is pretty typical, and I have not made any weird tweaks. I also don't even have any other browser installed.

  • mccrispy

    BitFlipper, you are not alone! I have a clean install of Win7 Enterprise that was immediately updated to IE9 via Windows Update. The only way I can get 32-bit by default is to create a shortcut to the 32-bit version and then "pin" the shortcut. I'd still like a real solution though.

  • cbae

    @BitFlipper:

    When I drag a URL to the desktop, the shortcut always brings up the 32-bit version. I checked this on both a Windows 7 Pro machine and a Windows 7 Ultimate machine.

    I checked the Internet Options ' Programs dialog, and it says "Internet Explorer (64-bit) cannot be the default browser". 

    The 64-bit version shouldn't even be allowed to be the default.

    What I would do is set a different browser (e.g. Chrome or FireFox) as default, and then set IE back as the default to see if that fixes the problem.

     

  • Gaviao

    I had the same problem in Windows 7 Professional that also had Google Chrome factory installed as the default browser.

    The solution that worked for me was to (i) rename the folder Internet Explorer under Program Files, (ii) run Internet Explorer from Program Files (x86) (iii) set IE as default.

    A few days later I noticed that Windows Explorer would keep opening folders in a new window and by restoring the Internet Explorer folder name in Program Files the problem disappeared and IE9 32-bit is still the default browser

  • taxlady

    All of this has also happened to me.  I was having "IE has stopped working" so often that it was unusable.  I went to Firefox then when I came back and wanted to download IE9 I got the 64 bit version which is not supposed to be the default browser.  I have tried some of your solutions but will try them again.  I still cannot play a video in IE9 because it keeps telling me IE has stoped working. Unfortunately my work website does not recognize Firefox so I must use IE.

  • taxlady

    I did as above and went into Program FIles (X86) and there was IE9 32 bit.  I made a shortcut to the desktop.  I unpinned IE9 64 bit from the start menu and the task bar, deleted the IE9 64 bit shortcuts.  I then pinned the 32 bit version to the start menu and taskbar and VOILA!  Now we will see if I get IE has stopped working errors again.  I am going to make "IE has stopped working" as my new motto.

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.