Microsoft dropped support for XP in SQL Server 2012. Internet Explorer 9 doesn't run on XP. Even Adobe has dropped XP support in LightRoom 4. I think the list goes on and on but it shouldn't come as a huge suprise that a framework that ships in a OS in 2012 would work in an os that shipped in 2001.