@elmer: I tried on two machines and in both didn't work, even the Paste command in the context menu was disabled, weird.