Site Feedback Thread

8 posts

PDC Video playback issues

Back to Forum: Site Feedback
  • User profile image
    danc

    I love the content of the PDC Videos and I am thankful that Microsoft and Channel 9 are making them available for all to see. Thank you!

    However, I do have a couple of annoying issues with the video player, specifically the PDC videos that show the people talking and the slides/demos side-by-side:

    1) Frequent stuttering (every few minutes, also after resuming playback from pause). I have Verizon FIOS with >15MB speed and a new Quad processor so I don't think it's a bandwidth issue on my side.

    2) When expanding to full screen (the only way to really see the detail on these side-by-side videos), the control bar at the bottom slides out of view and I can't get it to come back (tried moving mouse to various edges, hovering nearby, left and right clicking). Once it goes away, the only way to get it back is to hit ESC.

    I don't know if it's just me, but I hope these issues can be fixed soon. I have the latest Silverlight installed and I thought that Silverlight was supposed to make video playback better but so far it's actually worse for me than Windows Medial Player.

    Keep up the good work!

    Dan

  • User profile image
    LauraM

    Hey Danc, remember that under the "Download" area there is a WMV (high) link that you can click to download or play directly in Windows Media Player... in case these other problems don't get fixed right away

  • User profile image
    jeffsand

    LauraM said:
    Hey Danc, remember that under the "Download" area there is a WMV (high) link that you can click to download or play directly in Windows Media Player... in case these other problems don't get fixed right away
    we've seen a few reports of these and are investigating. one thing we've found is that if you pause the player and allow it to buffer a bit, the issues tend to go away.

    i'll follow up when we know more.

  • User profile image
    joechung

    jeffsand said:
    LauraM said:
    *snip*
    we've seen a few reports of these and are investigating. one thing we've found is that if you pause the player and allow it to buffer a bit, the issues tend to go away.

    i'll follow up when we know more.

    Buffering is broken when you get to the end of a video.  It gets stuck in a loop and basically repeats the beginning of the last chunk over and over.  The two videos where I had this problem were the Panel: The Future of Programming Languages and Deep Dive: Dynamic Languages on .NET.

    Also, the iPod version of the Deep Dive: Dynamic Languages on .NET video is truncated and is missing over half of the content.

  • User profile image
    Sikosis

    I have to say -- the video coverage of PDC on Channel9 has been sh*thouse ...

    Videos don't play ... they say Media Failure.

    Video Downloads don't download saying connection refused or no route to host.

    Video Downloads when they do work ... file comes down and then won't play in ANYTHING.

    It's been ... what ... a week since PDC and I've managed to see 1 video -- which I had to restart twice, as when you pause anything that's playing you then can't come back to it.

    Absolutely terrible -- if this was also meant to be a way to showcase Silverlight -- it showcases that it's not ready for primetime.

  • User profile image
    Duncanma

    Sikosis said:
    I have to say -- the video coverage of PDC on Channel9 has been sh*thouse ...

    Videos don't play ... they say Media Failure.

    Video Downloads don't download saying connection refused or no route to host.

    Video Downloads when they do work ... file comes down and then won't play in ANYTHING.

    It's been ... what ... a week since PDC and I've managed to see 1 video -- which I had to restart twice, as when you pause anything that's playing you then can't come back to it.

    Absolutely terrible -- if this was also meant to be a way to showcase Silverlight -- it showcases that it's not ready for primetime.
    I don't think this has anything to do with Silverlight, since you have problems downloading the videos as well. I suspect there is an issue between your machine and our video host, which would account for the media failure messages and the 'no route to host'. Do you normally have issues playing or downloading Channel 9 videos?

    Obviously I'm biased, but I've been watching many videos without any trouble at all... downloading them or watching them directly in the player... so while I'm sure you are having these problems, it definitely isn't happening to most people viewing this site. Some questions for you ...

    What browser are you using?
    Are you going through a proxy?
    Are videos are at this host: mschnlnine.vo.llnwd.net ... can you do a tracert to that host?

  • User profile image
    joechung

    Duncanma said:
    Sikosis said:
    *snip*
    I don't think this has anything to do with Silverlight, since you have problems downloading the videos as well. I suspect there is an issue between your machine and our video host, which would account for the media failure messages and the 'no route to host'. Do you normally have issues playing or downloading Channel 9 videos?

    Obviously I'm biased, but I've been watching many videos without any trouble at all... downloading them or watching them directly in the player... so while I'm sure you are having these problems, it definitely isn't happening to most people viewing this site. Some questions for you ...

    What browser are you using?
    Are you going through a proxy?
    Are videos are at this host: mschnlnine.vo.llnwd.net ... can you do a tracert to that host?

    My buffering issues at the end of the videos -- all 12 or so videos I have seen in the player thus far, not just the two I mentioned -- were via the Silverlight 2 plugin on Firefox 3.0.3 and Safari 3.1.2 on Mac OS X.  Additionally, the stuttering issues occur on both browsers with different symptoms.  On Firefox, small bits of video/audio stutter, and on Safari, small bits of video/audio are skipped entirely.

    No proxy (running from home on 1.5 Mbps DSL). I'm able to do a traceroute from my machine all the way to Limelight's CDN network.

  • User profile image
    aelwyn

    Sikosis said:
    I have to say -- the video coverage of PDC on Channel9 has been sh*thouse ...

    Videos don't play ... they say Media Failure.

    Video Downloads don't download saying connection refused or no route to host.

    Video Downloads when they do work ... file comes down and then won't play in ANYTHING.

    It's been ... what ... a week since PDC and I've managed to see 1 video -- which I had to restart twice, as when you pause anything that's playing you then can't come back to it.

    Absolutely terrible -- if this was also meant to be a way to showcase Silverlight -- it showcases that it's not ready for primetime.
    I'm also having similar problems that Sikosis posted above.  Some of the videos do not play they only show a "Media Failure" message.
    Some do play and I believe it is linked to file size.  It seems that our anti-virus server has a limit and these videos are too large to pass through it.  Just thought this might help anyone else with the same problems.

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.