Site Feedback Thread

16 posts

Cannot dl video, it always slows down and interrupts

Back to Forum: Site Feedback
  • coolpero
  • Duncanma

    @coolpero:I wasn't able to repro the issue, but downloading can be different for different people depending on the edge cache they are hitting. To help resolve this, what I've done is moved the file to another media server, which (being a new URL) means you won't be going through the same CDN edge node to get the file. You can go back to the post to download it, or you can try right clicking on this file

    High Quality WMV (2.5 Mbps)

    and saving it locally.

  • Candunn

    I haven't had luck with any video, if I try to download it, it is very slow, then it will only do a part of the video like 10 secs, and stop.

    The link above didn't work.

    This is terrible, I've seen some other threads why can't you guys fix this??

     

  • Maddus Mattus

    Because it's not up to them where you download the file from.

    It's up to the cloud (home router/ISP/Internet/Azure/Channel9).

    So they can't see where in the chain it fails,.. They can only check if the file is availible from their location.

    So, to help them, can you eliminate that the problem lies in your internet connection by;

    Downloading a large WMV file from a different website other then Channel9?

    Doing a traceroute to the name of the server you are downloading from?

  • Charles

    @Candunn: As Maddus suggested,

    please run

    tracert ecn.channel9.msdn.com

    send us the output

    I suspect the issue is with your ISP blocking this content or it's a side effect of downloading content in a proxy-controlled network (are you doing this from work or home?).

    C

  • nocturns2

    I thought this was only happening to me.

    I saw this link topic which had 4 replies and I thought to my self that they must be from other people not being able to download videos from channel 9.

    Referencing the above regarding tracert and downloading large video files from other sites.

    I (have successfully and) can download large files from any other sites that I've tried to do so, that includes video files.

    For the past year I have not been able to successfully download or view a complete video from channel 9. When I realize that the content I'm after is channel 9 I cringe!

    Below is the results of running the tracert command from above:

    Tracing route to mschannel9.vo.msecnd.net [70.37.129.243]
    over a maximum of 30 hops:

      1    33 ms    33 ms    33 ms  10.20.12.1
      2    31 ms    31 ms    33 ms  static-64-222-165-50.man.east.myfairpoint.net [64.222.165.50]
      3    43 ms    41 ms    42 ms  POS5-0.GW1.NYC9.ALTER.NET [208.192.176.109]
      4    43 ms    41 ms    42 ms  0.so-1-0-1.XT2.NYC9.ALTER.NET [152.63.99.182]
      5    43 ms    43 ms    43 ms  0.so-6-0-0.XL4.NYC4.ALTER.NET [152.63.17.97]
      6    43 ms    41 ms    43 ms  TenGigE0-5-1-0.GW8.NYC4.ALTER.NET [152.63.21.73]
      7    44 ms    41 ms    41 ms  microsoft-gw.customer.alter.net [65.206.120.34]
      8    44 ms    43 ms    42 ms  xe-1-0-0-0.ewr-96cbe-1a.ntwk.msn.net [207.46.46.212]
      9    44 ms    43 ms    43 ms  10gigabitethernet6-1.ewr-xmx-edgcom-1a.ntwk.msn.net [207.46.44.198]
     10    44 ms    44 ms    44 ms  cds218.ewr9.msecn.net [70.37.129.243]

    Trace complete.

    The results show that it can make it to channel 9, but it doesn't include a return route.

    My question is why do the videos start downloading (and I've gotten as far as 40%) before throttling down 1kps and ultimately the download gets interrupted (terminated).

    Trying to watch the videos online instead of dowloading results in a a choppy and time consuming exercise that can last for hours without completion.

    I don't really have the time to diagnose why I can't get the content from channel 9, although many of the microsoft resources links direct me here. So I usually resign myself to finding it somewhere else if possible.

    I feel there is alot that I'm missing out on and would like to have UX with channel 9 that is at minimum tollerable. Currently, I have been trying to download a 14+ min video (109 MB) for the past 30+ mins, it has been interrupted twice and now it's at 4% indicating that it has 30 min 50 sec remaining. Update now it 31 min 10 sec remaining.

     

  • SidPrice

    I see just the same type of very poor performance and have done for a very long time. It is so bad that like "nocturns2" I do my best to avoid Channel 9. This so frustrating, always the blame goes back to the ISP no matter how many times users point out that they can download and play video from other sites without problems.

    I note transfer speeds of maybe 25-30% of that from most other sites I use. It would be really good if someone would take ownership of this issue and address it. This issue has to be driving many people away from the site. Especially since the download is also so unreliable, never mind the streaming.

    Sid.

  • Maddus Mattus

    I think they are working on it,..

    It sounds like an Azure CDN bug/feature,..

    It's out of their hands then really,..

  • Buzza

    I am also only getting 22 kB/sec (in the office and at home so different networks in Australia)

    Did the tracert and here are the results:

    tracert ecn.channel9.msdn.com

    Tracing route to mschannel9.vo.msecnd.net [70.37.159.141] over a maximum of 30 hops:

    1     *        *        *     Request timed out.
    2     8 ms     1 ms     1 ms  113.11.254.125.unassigned.comindico.com.au [125.254.11.113]  
    3     1 ms    <1 ms     1 ms  129.38.168.202.static.comindico.com.au [202.168.38.129]  
    4    13 ms    13 ms    13 ms  syd-nxg-men-crt2-ge-5-1-0.tpgi.com.au [202.7.173.229]  
    5    14 ms    13 ms    13 ms  202.7.171.78  
    6    13 ms    15 ms    23 ms  10gigabitethernet5-1.syd-xmx-edgcom-1b.ntwk.msn.net [70.37.149.62]
    7    14 ms    13 ms    14 ms  cds10.syd9.msecn.net [70.37.159.141]

     

    I run tech training session and use Channel9 all the time - would be nice to get this fixed (all other content source are > 1MB/sec)

  • indigophoen​ix

    @Charles

    Experiencing the same issues as a lot of folks here.  And, yes, I can get content from other places without the same trouble.

    Here's a traceroute, hopefully that will be of some use to you.  Thanks in advance!

    Tracing route to mschannel9.vo.msecnd.net [65.54.80.198]
    over a maximum of 30 hops:

      1     1 ms    <1 ms    <1 ms  192.168.1.1
      2     5 ms     5 ms     6 ms  10.49.112.1
      3    13 ms     7 ms     5 ms  gig3-3.ashtoh1-rtr1.neo.rr.com [24.164.108.137]

      4     7 ms    17 ms     7 ms  gig1-48.ashtoh1-swt401.neo.rr.com [24.164.108.19
    4]
      5    12 ms    10 ms     9 ms  tge1-2.clvhoh1-rtr2.neo.rr.com [24.164.117.144]

      6    14 ms    12 ms    11 ms  tge0-1-0.clevoh1-rtr01.neo.rr.com [24.164.117.12
    7]
      7    13 ms    14 ms    13 ms  tge11-0-0.ncntoh1-rtr1.neo.rr.com [24.164.118.96
    ]
      8    17 ms    17 ms    19 ms  tge4-0-1.ar01.clmkohpe.mwrtn.rr.com [65.25.137.1
    3]
      9    17 ms    17 ms    17 ms  ae1.tr00.clmkohpe.mwrtn.rr.com [65.189.140.128]

     10    28 ms    27 ms    35 ms  ae-4-0.cr0.chi30.tbone.rr.com [66.109.6.68]
     11    46 ms    27 ms    27 ms  ae-0-0.cr0.chi10.tbone.rr.com [66.109.6.20]
     12    40 ms    39 ms    39 ms  ae-4-0.cr0.nyc20.tbone.rr.com [66.109.6.24]
     13    38 ms    68 ms    39 ms  107.14.19.147
     14    39 ms    39 ms    40 ms  66.109.10.154
     15    39 ms    39 ms    39 ms  ge-1-2-0-0.nyc-64cb-1a.ntwk.msn.net [207.46.47.2
    10]
     16    39 ms    41 ms    39 ms  ge-7-0-0-0.nyc-64cb-1b.ntwk.msn.net [207.46.47.2
    1]
     17    41 ms    41 ms    42 ms  ge-1-3-0-0.bl2-64c-1b.ntwk.msn.net [207.46.43.21
    ]
     18    87 ms    39 ms    40 ms  xe-11-0-0-0.bl2-96c-1a.ntwk.msn.net [207.46.43.9
    7]
     19    48 ms    44 ms    49 ms  10gigabitethernet10-2.bl2-xmx-edgcom-1b.ntwk.msn
    .net [207.46.35.173]
     20    40 ms    39 ms    39 ms  cds260.iad9.msecn.net [65.54.80.198]

    Trace complete.

  • indigophoen​ix

    Well, the downloading is finally working as it should and, not wanting to be the ungrateful type, I wanted to thank the folks who rectified the problem. Much appreciated.

  • asdfghh

    No, the problem still exists, but maybe it is not as constant, Maybe there is some kind of bandwidth limit in ch9? Cause i can watch 1-2 videos with no problem but after than the speed drops dramatically. This is a horrible bug that should be addressed instantly, but judging from the comments here and in other threads this is becoming just a property of this site.

  • Duncanma

    @asdfghh: We certainly don't do any throttling based on the amount you've downloaded... could you give specific examples of videos that worked well and those that were slow?

  • AlongThese​Lines

    Having the same problem trying to watch Roger Dougherty's business intelligence videos over the last week. No issues streaming/downloading videos from other sites.

    Tracing route to mschannel9.vo.msecnd.net [65.54.95.160] over a maximum of 30 hops:

    1     1 ms     1 ms     1 ms  192.168.0.1
    2    40 ms    39 ms    40 ms  tukw-dsl-gw55-247.tukw.qwest.net [63.231.10.247]
    3    40 ms    40 ms    40 ms  tukw-agw1.inet.qwest.net [71.217.185.177]
    4    40 ms    40 ms    41 ms  sea-edge-12.inet.qwest.net [67.14.41.26]
    5    45 ms    41 ms    40 ms  63-234-17-26.dia.static.qwest.net [63.234.17.26]
    6    40 ms    41 ms    41 ms  ge-7-3-0-58.wst-64cb-1a.ntwk.msn.net [207.46.46. 41]
    7    45 ms    42 ms    44 ms  ge-1-0-0-0.cpk-64c-1a.ntwk.msn.net [207.46.43.21 8]
    8    47 ms    49 ms    49 ms  10gigabitethernet1-2.cpk-xmx-edgcom-1a.ntwk.msn. net [207.46.44.34]
    9    40 ms    41 ms    41 ms  cds122.sea9.msecn.net [65.54.95.160]

    hth,

    Kris

  • Mindfrell

    I have this exact same issue as well. Videos will begin to download at full speed, only to slow down and stop within 10 seconds of starting. This has been a problem for well over a year now, and I have never seen it happen anywhere else.

    From a residential ISP (Bellsouth DSL) - 

     

    C:\dev>tracert ecn.channel9.msdn.com

    Tracing route to mschannel9.vo.msecnd.net [65.55.87.90]
    over a maximum of 30 hops:

    1 1 ms <1 ms <1 ms 192.168.1.1
    2 6 ms 5 ms 5 ms adsl-74-161-129-1.mia.bellsouth.net [74.161.129.1]
    3 5 ms 5 ms 6 ms 205.152.108.1
    4 5 ms 5 ms 5 ms her00mia-ge-6-3.bellsouth.net [205.152.145.161]
    5 26 ms 6 ms 6 ms 12.81.8.94
    6 5 ms 5 ms 5 ms 12.81.8.67
    7 11 ms 10 ms 10 ms 74.175.192.170
    8 41 ms 43 ms 44 ms cr81.fldfl.ip.att.net [12.122.106.94]
    9 43 ms 43 ms 43 ms cr2.ormfl.ip.att.net [12.122.1.45]
    10 44 ms 43 ms 42 ms cr1.ormfl.ip.att.net [12.122.5.185]
    11 45 ms 42 ms 42 ms cr2.hs1tx.ip.att.net [12.122.1.5]
    12 43 ms 43 ms 43 ms cr1.dlstx.ip.att.net [12.122.28.157]
    13 44 ms 43 ms 43 ms cr2.dlstx.ip.att.net [12.122.1.210]
    14 40 ms 41 ms 43 ms cr81.ftwtx.ip.att.net [12.122.100.69]
    15 38 ms 39 ms 38 ms gar5.auttx.ip.att.net [12.122.100.73]
    16 40 ms 40 ms 40 ms 12.248.87.6
    17 40 ms 40 ms 40 ms 204.152.140.17
    18 49 ms 49 ms 48 ms xe-8-2-0-0.sn1-96cb-1a.ntwk.msn.net [207.46.46.179]
    19 46 ms 46 ms 47 ms 10gigabitethernet5-1.sn1-xmx-edgcom-1b.ntwk.msn.net [207.46.33.110]
    20 48 ms 48 ms 50 ms cds85.sat9.msecn.net [65.55.87.90]

  • Mike Greenway

    I had this problem months ago and they finally told me it was my ISP. The ISP put in new optical cable and this sites silverlight still will no stream correctly BUT HTML5 now works perfectly.

    HTML6 make any diffenace for you?

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.