Site Feedback Thread

32 posts

Silverlight Player Crashes in Firefox

Back to Forum: Site Feedback
  • DTK

    So any new fixxes or workarounds for this? Do find it odd that the player on:

    http://www.silverlight.net/learn/videos/all/fullscreen-window-pinning/

    doesn't get that error. They must have the solution but what is it?

  • Duncanma

    @DTK: is this still happening for you? We modified our player to not use full-screen pinning when in FireFox, therefore avoiding the bug... but if you are still seeing it then I'm confused.

  • Duncanma

    @DTK: FYI, I went and tried that page in FireFox and it froze my FF browser when I agreed to the security prompt. Is it possible you already gave silverlight.net permission from another browser (like IE) ?

  • felix9

    I've seen this behaviour with other players, even other Silverlight dialogs like requesting access to my camera, so its a common prblem with those dialogs, not a C9 specific problem.

  • new2STL

    FF: 3.6.15 (20110303), SL Plug-in: 4.0.60129.0

    I'm having no problems with it at all, even on previous versions of FF and SL, only the 1st time I run in fullscreen I have to add an exception (by popup warning) to let FF launch SL in fullscreen for Ch9 site (url)

    Some camera drivers are bugged and crash cause any access to the cam (even if only to inspect the cam name and supported resolutions) trigger the cam app to launch.

    I see lots of this behavior cause on my old work I have to deal with video conferencing (by apps and browser apps) and every cam (and even on every model inside the same brand) have corner cases

    Try see if the cam have updated drivers, but not much to do unless write a report for SL forum and cam tech forum (if have)

  • DTK

    @Duncanma:  I'm building my own player and run into this "crashing" behavior. But on the player I mentioned ( http://www.silverlight.net/learn/videos/all/fullscreen-window-pinning/ )
    I just get the security question (as it should be) and no crashing. I haven't accepted it in other browsers and can go fullscreen in Firefox and get the security box time after time without crashing. So I'm wondering what did they do different...

  • Duncanma

    @DTK: Odd, because I also get the security prompt on that player, but it *does* crash my version of FireFox. This bug has been filed with the SL team though, and I know it has been discussed with the FireFox team as well, so hopefully one team or the other will make the changes required to fix it. For now, we've coded our player to not do full screen pinning if the user is using FireFox

  • Sluse

    Problem can be solved from IE untill microsoft get them self together, i have reported the bug to microsoft and asked why the popup request should be there, and if it not was to joke around with people

    anyone knows what crtl+alt+del, esc, & power-button is if they can't get out of full-screen... Big Smile

  • GarveysGhost

    You guys at Microsoft should really sort this out, it reflects badly on you. This bug has been on your player for at least 6 months now. I develop on the Microsoft platform, however like most other developers, I also refuse to use IE. Restricting your audience due to the browser of choice is just an epic fail.

  • Duncanma

    @GarveysGhost: We don't restrict you though, we just have a small difference in functionality between our player in FF and our player in other browsers. We disable the 'pinned' full screen feature in FF, but you are still able to watch the video and even go full screen in FF. Let me know if that isn't the case, we certainly do not intend to block people from watching our videos in FireFox.

     

  • mocthezuma

    Same thing here.

    I find it crashes every time I try to launch fullscreen mode, but only the first time.

     

    After the browser freezes for a couple of minutes, it comes back to life and tells me silverlight has crashed. When I then reload the stream and click on fullscreen it works fine.

  • Bjartewe

    Here's a solution that worked for me, it doesn't require you to use another browser:

    http://timheuer.com/blog/archive/2010/08/16/enable-silverlight-debugging-in-firefox-visual-studio.aspx

    I didn't find the entry specified in the link, but when I set dom.ipc.plugins.enabled to false, it worked - pop up don't make FF crash anymore and I can give the video full screen access.

  • golnazal

    opening thread

     

  • Geoffreyk

    removing spam

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.